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Setting Up Documents and Using Templates
You can create new documents in the following ways:

• Open the software, which uses NORMAL.igr as a starting template, and
create a new document.

• Use the New command and choose the template you want to use to create the
document.

When you start the software, a new, blank document opens. You can format each
new document you create or use a pre-formatted template as a starting point for a
new document. You can work in the blank or pre-formatted document and save
the changes when you are finished.

When you create a document, the document is displayed on your screen. You can
use the commands on toolbars and in menus to add information to your
document, and you can use edit commands to modify the information in your
document.

Any changes you make are temporarily stored in memory. You have to save the
document to preserve the changes to your document. You can also save
documents in a specific format.

Using Templates as a Starting Point
Regardless of the method you use to create a document, a template is used as a
starting point in creating the document. A template is a file that provides tools
such as text, formats, geometry, dimensions, units of measurement, and styles
that will be used to produce a new document that uses a specified format. You
can also edit the property set of the template to include default values for some of
the properties as well as the additional custom properties you need to manage
your documents.

The template that you use depends on the type of information you want to put in
the document. For example, you would use an electrical schematic template to
create a drawing that contains a schematic of an electrical component.

Opening Existing Documents
The Open command on the File menu opens existing documents. The software
keeps track of the documents you worked on last. These documents are listed at
the bottom of the File menu. To open one of these documents, you can choose it
from the list. The Options command on the Tools menu allows you to set the
number of entries displayed in the list.
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Setting Up Properties for a Document
Once you create a new document or open an existing one, you might want to set
document properties so that you can easily find the document later. You might
also want to set up the units of measure that the document will use. With
document properties, you can store document information with the document
itself, instead of in a separate database. To set the properties, you can click the
Properties command on the File menu.

With the Properties command, you can view, edit, and store properties for a
document. Document properties can include the title, the author, and keywords
that identify important information. These properties also can include document
statistics, such as document size and the date that a document was created and last
modified. Some properties are updated automatically by the software, such as the
date the document was last modified.

Setting the Document’s Units of Measure
The unit of measure settings for a document are stored as a property. If you set
the units of measure, all the measurements in the drawing are affected. For
example, if you set the length unit of measure to inches, then all the
measurements in the drawing display in inches.

You can set units of measure in both English and metric units for values such as
length, area, or angles. You can change the unit of measure at any time while you
are drawing, and the document still retains complete accuracy of the
measurements in the drawing.

The precision readout sets the number of significant figures to display. It sets the
accuracy of the unit readout value. The precision setting does not alter the
numbers that you type into the fields, only the display of the numbers in the field.
Values ending in 5 are rounded up. For example, if the precision readout is .123
and you draw a line that is 2.1056 inches long, then the line value length is
rounded. The length value appears as 2.106 inches long. If you are using mm as
your drawing sheet units, you can have the values display in the fields as 3.5 mm
or 3.50 mm.

Tip  When you set the units of measure for a document, the settings do not affect
the dimensional values for the document. You can set units for the dimensional
values with the Dimension Properties dialog box. You can access this dialog box
by selecting a dimension and then clicking the Properties command on the
shortcut menu. You can also set the dimension units by editing a dimension style
with the Dimension command on the Format menu.

Saving a Document as a Template
Sometimes you might want to make a copy of the same document as a starting
point for creating other documents. In these cases, you can create a template to
use as a starting point for many different drawings. A template is a collection of
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settings that you use over and over in different drawings. The settings might
include drawing sheet settings, scales, actual elements that you draw, and a
background sheet.

To create a template, just save the current document with the Save As Template
command on the File menu. This command saves the document in the
TEMPLATE directory located in the directory where you installed the software.
A different file extension in the name of the document is not necessary. To base
new documents on the template, choose the New command on the File menu and
select the template from the list. You can also open the template and save the
document under another name.

Tip  You can change the directory where templates are saved by selecting the
Options command on the Tools menu and setting the directory that you want on
the File Locations tab of the Options dialog box.

Working with Several Open Documents
Several documents can remain open in the same session. You can use the Cut,
Copy, and Paste commands to move or copy information between the documents
or within one open document. You can use commands on the Window menu to
arrange all the open documents so that you can view them easily.

You can also use the Object command on the Insert menu to import objects, such
as drawings, spreadsheets, or text created in other software, into an open
document. You can link or embed the imported objects. You can also drag
information from another document into an open document.
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Templates Overview
A template is used as a starting point in creating a document. A template is a file
that provides tools such as text, formats, geometry, dimensions, units of
measurement, toolbars, and styles that are used to produce a new document that
uses a specified format.

The template that you use depends on the type of information you want to put in
the document. For example, if you want to create a drawing that contains a
schematic of an electrical component, you can use an electrical schematic
template.

When you base a document on a particular template, that template automatically
points to the symbols that you would most likely use for that type of document.
The Symbol Explorer displays the appropriate symbol set for the task.

When you select a specific template, tools are available that allow you to create
either a schematic diagram or a precision drawing.

Schematic diagrams are primarily created using symbols, connectors, and text at a
1:1 scale. Schematic diagrams do not represent a logical flow. The Schematic
toolbar is available when you select a template designed to create a schematic
diagram.

Precision drawings represent physical elements such as lines, arcs, curves, and
rectangles that you draw precisely with the Draw toolbar. Precision drawings are
created at real-world scale, and you can maintain relationships between elements
in precision drawings.
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Architectural Templates Overview
You use these precision templates to produce architectural designs and drawings
according to accepted industry standards.

• Architectural (Imperial)—This template has imperial units in feet and inches,
ANSI and architectural sheet sizes and borders, architectural fill styles, and
provides symbols based on AIA standards for residential and commercial
designs.

• Architectural (Metric)—This template has metric units in meters and
centimeters, ISO standard architectural sheet sizes and borders, architectural
fill styles, and provides symbols based on AIA standards for residential and
commercial designs.

The ANSI, DIN, BSI, ISO, and JIS dimensioning standards are also available in
these templates. When you open these templates, the Draw toolbar appears,
containing tools to help you create precision drawings.

Production Drafting Workflow for Floor Plans
You can produce full sets of production drawings according to the AIA standards.

1. Set up the sheet.

Select an appropriate sheet size and scale that allow you to draw the design.
The default scale is 1/4" = 1', which is appropriate for the average plan on a
D-Size sheet.

2. Select a border or create one.

The Architectural templates are delivered with ten border sizes. Select the
borders from the Sheet Setup command on the File menu so that they appear
in the current design. On the Background tab, select the background sheet to
display with the working sheet. Use the Select Tool to position the graphics
appropriately in the border.

Note  The borders were designed from guidelines from the Construction
Specifications Institute (CSI).

3. From the View tab on the Options dialog box, set the grid settings to Grid
style to Static, Grid spacing to 1, and Grid index to 1.

4. Draw the perimeter walls.

Workflow A:  Draw the approximate perimeter walls of the floor plan, using
the Place Doubleline and SmartSketch commands. Use the Trim, Trim to
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Corner, and Extend to Next commands for any intersection cleanup between
elements where walls overlap or do not intersect cleanly.

Verify on the Tools menu that Maintain Relationships is set on. Draw the
approximate perimeter walls of the floor plan, using the Place Doubleline,
SmartSketch Settings, and PinPoint commands. Then adjust the distance
between walls (doubleline graphics) using the Select Tool on the Draw
toolbar to make precision distances with the PinPoint command. Use the
Trim, Trim Corner, and Extend to Next commands for any intersection
cleanup between elements.

Short cut keys F9 and F12 for PinPoint are useful when you draw walls.

Avoid trimming for openings, doors, or windows.

Press and hold the Shift key while using the Place Doubleline command; this
action prevents a beginning or end cap from being placed. (Pressing and
holding the Shift key while using the Place Doubleline command is useful for
tracing.)

5. Draw the interior walls.

Using the same techniques and commands you used to draw the perimeter
walls, add the appropriate interior walls and adjust accordingly.

6. Place door and window symbols.

Using the Symbol Explorer, select the Doors folder from the Plan Symbols
folder in the tree view. Drag the door symbols onto the represented wall
elements, and use the bold parameters that appear in the Attribute Viewer to
change the size of the door and the handles that appear to orient the door to
the position you want. Repeat the same steps you used to place doors for
placing windows and all other types of symbols.

You can use two methods to place multiple copies of the same symbol:

• Holding down the right mouse button, drag the symbol into the template.
When you release the right mouse button to place the symbol, you are
prompted with two options. Click Stamp Here, and use the left mouse
button to place multiple copies of the symbol.

• Press the Ctrl key on the keyboard as you drag in a symbol with the left
mouse button. Place the first instance of the symbol while holding down
the Ctrl key. Once you have placed the first symbol, you can release the
Ctrl key and use the left mouse button to place multiple copies of the
symbol.

7. Annotate the drawing.
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Use text and dimensioning commands to annotate the drawing. Text is
entered in paper units regardless of the sheet scale. To label windows and
doors, use the labels that automatically appear on symbols when you double-
click them. Or use labels provided in the Label directory in the Plan Symbols
directory.

The following symbol sets aid in production drafting.

Content Description

Elevation Symbols Symbols of typical elevation view
content based on AIA standards and
other common designs.

Plan Symbols Symbols of typical plan view content
based on AIA standards and other
common designs. Some symbols such
as doors and windows can be modified
by parameters that appear when the
symbols are placed.
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Basic Diagramming Templates Overview
You use these templates to produce business diagrams.

• Imperial Template—This template has imperial units in decimal inches,
ANSI sheet sizes, ANSI dimensioning and ANSI text.

• Metric Template—This template has metric units in millimeters, ISO sheet
sizes, ISO dimensioning, and ISO text.

Basic diagramming symbols are available in the Symbol Explorer for these
templates. The Schematic toolbar containing tools to create diagrams appears on
the left of the drawing window.

Setting Up a Basic Diagram

Tip  You can create business diagrams with Maintain Relationships set on or off.

1. Set up the sheet.

Select an appropriate sheet size and scale that allow enough paper space to
draw. The default scale is 1:1.

2. Prepare to draw.

Set the drawing aids to your preferences. Use the SmartSketch Settings, Grid
Display, and Grid Snap commands.

For more grid options click the View tab on the Options dialog box to set the
grid style to either dynamic or static, and set the static grid to the preferred
grid spacing.

• These settings provide visual feedback to you to improve the workflow
while you draw. To create clean diagrams, use Grid Snap with a static
grid displayed.

• Placing symbols and connectors on a static grid produces high quality
results.

• You can set grid display and snap by right clicking.

Simple Diagramming Workflow
1. Drag symbols from the Symbol Explorer.

2. Use the Connector command to connect symbols.
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3. Double-click each symbol to add text.

Optimal Diagramming Workflow
1. Place basic diagramming symbols by using the mouse to drag from the

Symbol Explorer.

While dragging a symbol, use the left/right arrow keys on the keyboard to
rotate the symbol dynamically during placement.

Use the up/down arrow keys to select different drag points on the symbol
before placement.

If you press the Alt key during symbol placement, the alignment indicators
are temporarily disabled, allowing you to place a symbol using grid snap or
visual alignment.

You can use two methods to place multiple copies of the same symbol:

• Holding down the right mouse button, drag the symbol into the template.
When you release the right mouse button to place the symbol, you are
prompted with two options. Click Stamp Here, and use the left mouse
button to place multiple copies of the symbol.

• Press the Ctrl key on the keyboard as you drag in a symbol with the left
mouse button. Place the first instance of the symbol while holding down
the Ctrl key. Once you have placed the first symbol, you can release the
Ctrl key and use the left mouse button to place multiple copies of the
symbol.

2. Connect the symbols by using the Connector command.

When drawing connectors, you should set Clearance. Type the minimum
distance from the symbols that you would like the first turn in the connectors
to occur. This action allows you to control the visual consistency of
connectors that make right-angle turns just before they attach to a symbol.

When you draw a connector to a symbol, approach the symbol from the
direction you want the connector placed. As the pointer intent zone nears the
symbol, suggested targets for the connector appear.

The connector end point can be located on a target or any other symbol
geometry.

If you press the Alt key while drawing a connector, the diagonal drawing
mode will be temporarily activated, allowing the connector to be drawn at any
angle with or without grid snap.

3. Place text.
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Double-click symbols to place text in the center of the symbol.

The active text settings in the file are used.

To highlight existing text for properties editing or moving, pause the pointer
over text until the PickQuick indicator appears. Then click and select the
numbered box that represents the text.

Right-click on the highlighted text to edit properties.

To move the highlighted text, click the green lock to unlock. Move the text to
a new position. Note that text is entered in paper units regardless of the sheet
scale.

4. Finish the diagram.

Use color to modify the symbols and connectors to enhance the drawing.

The following symbol sets are aid in drawing diagrams.

Content Description

\Program Files\SmartSketch
\Symbols\Diagramming
\Basic

Common business diagramming
symbols. You can double-click these
symbols to place text. These symbols
also have special behaviors for
enhanced placement and
modification.
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Site Templates Overview
You use these precision templates to produce site designs and drawings according
to accepted industry standards.

• Site (Imperial)—This template has imperial units in feet and inches, ANSI
and architectural sheet sizes and borders, and architectural fill styles. It also
provides symbols based on AIA standards for residential and commercial
designs.

• Site (Metric)—This template has metric units in meters and centimeters, ISO
standard architectural sheet sizes and borders, and architectural fill styles. It
also provides symbols based on AIA standards for residential and commercial
designs.

The ANSI, DIN, BSI, ISO, and JIS dimensioning standards are also available in
these two templates. When you open these templates, the Draw toolbar appears,
containing tools to help you create precision drawings.

Production Drafting Workflow for Site Designs
You can produce full sets of production drawings according to the AIA standards.

Tip  To produce a fairly complex production drawing, you should set Maintain
Relationships off.

1. Set up the sheet.

Select an appropriate sheet size. The default scale is 1/4" = 1', which is
appropriate for the average plan on a D-Size sheet.

2. Reference a floor plan or open one.

Reference a floor plan by using the Object command on the Insert menu or by
dragging and dropping in the reference file. Or click the Open command to
open (translate) the file.

Tip  Any MicroStation, AutoCAD, dxf, or igr document can be a reference
file.

3. Create a foot print.

If you reference the plan, using the drawing tools on the Draw toolbar, you
can trace the outer perimeter of the reference plan to create the outline shape
of the building. Either delete or move the reference file to a layer and turn it
off.

4. Place symbols.
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Drag the landscape symbols into the document in the appropriate positions.

You can use two methods to place multiple copies of the same symbol:

• Holding down the right mouse button, drag the symbol into the template.
When you release the right mouse button to place the symbol, you are
prompted with two options. Click Stamp Here, and use the left mouse
button to place multiple copies of the symbol.

• Press the Ctrl key on the keyboard as you drag in a symbol with the left
mouse button. Place the first instance of the symbol while holding down
the Ctrl key. Once you have placed the first symbol, you can release the
Ctrl key and use the left mouse button to place multiple copies of the
symbol.

5. Annotate the drawing.

Use text and dimensioning to annotate the drawing. Text is entered in paper
units regardless of the sheet scale. To label site symbols, use the labels that
automatically appear on symbols when you double-click them.

6. Select a border or create one.

The Site templates are delivered with ten border sizes. Select the borders with
the Sheet Setup command so that they appear in the current design. On the
Background tab of the Sheet Setup dialog box, select the background sheet to
display with the working sheet. You should use the Select Tool to position the
graphics appropriately in the border.

Note  The borders were designed from guidelines from the Construction
Specifications Institute (CSI).

The following symbol sets aid in production drafting.

Content Description

Elevations Symbols Provide AIA and Intergraph standard elevation symbols
for commercial and residential Site design.

Plan Symbols Provide AIA and Intergraph standard plan symbols for
commercial and residential Site design.
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Mechanical Templates Overview
• ANSI Template—This template has imperial units in decimal inches, ANSI

sheet sizes and borders, implements the ANSI Y14.5 dimensioning standard,
and provides ANSI Y14.5 GD&T and American Welding Society (AWS)
Weld symbols.

• ISO Template—This template has metric units in milli meters, ISO sheet sizes
and borders, implements the ISO dimensioning standard, and provides ISO
GD&T and Weld symbols.

The DIN, BSI, and JIS dimensioning standards are also available in these two
templates.

When you open these templates, the Draw toolbar appears, containing tools to
help you create precision drawings.

Part Design Workflow

Tip  You should design individual parts with Maintain Relationships turned on.

1. Set up the sheet.

Select an appropriate sheet size. The default scale is 1:1, which is appropriate
for small parts.

2. Sketch the part.

Draw the elements, using the tools from the Draw toolbar and the
SmartSketch Settings command. As you draw, relationships are established
that capture your design intent.

Tip  As an example the system remembers when you draw a line
horizontally, vertically, or parallel to another line and maintains that
information when you modify the drawing. You do not need to give much
attention to the exact size of the part; it is often easier to dimension the part
and change the dimensions later.

3. Dimension the part.

Use SmartDimension and the other dimensioning tools to dimension the part.
These dimensions drive dimensions that can be changed to iterate your
design. Redundant dimensions are shown through the driven elements.

4. Refine the drawing.

Select individual dimensions and change the values to iterate your design.
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If you plan to use the part in a mechanism or assembly, then select all of the
geometry and create a symbol with an appropriate name.

Mechanism Modeling Workflow
• You can design mechanisms, using rigid body symbols.

• You should set Maintain Relationships on in the mechanism file.

1. Prepare the parts.

You must save each part in the mechanism as a symbol and turn Allow
Rotation by Relationships on, using the Symbol Authoring tools, so the parts
can act as a rigid body in the mechanism.

2. Start a new drawing.

You should create the mechanism in a new drawing with an appropriate sheet
scale for the whole mechanism. Set the symbol browser to the location of the
components.

3. Drag the parts.

Drag the parts into their rough location on the sheet, but do not give much
attention to precision placement or orientation.

4. Connect the parts.

Use the tools on the Relationship toolbar to establish the relationships
between the parts in the mechanism. Connect allows you to connect a specific
location on one part to a specific location on another part. Use relationship
indicators to determine the connection type, such as end point to center point
or end point to midpoint. You can also use specific tools to establish other
relationships, such as tangent, parallel, perpendicular, colinear, concentric,
and others.

5. Create driving dimensions.

Use SmartDimension or other dimensioning tools to establish the controlling
dimensions for the mechanism.

6. Move the mechanism.

Select a driving dimension and change the value to move the mechanism into
a specific configuration.
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Production Drafting Workflow
You can produce full sets of production drawings according to the ANSI
standards.

Tip  To produce a fairly complex production drawing, set Maintain Relationships
off.

1. Set up the sheet.

Choose an appropriate sheet size and scale that allow you to draw the part.
The default scale is 1:1, which is appropriate for small parts on an A-Size
sheet.

2. Draw the views.

Draw a principle view of the part using the draw tools (with precision key-in
values on the ribbon bar), SmartSketch Settings, and PinPoint. Draw other
views using SmartSketch Settings to align key edges from each view.

3. Annotate the drawing.

Use the text, dimensioning, GD&T symbols, and weld symbols to annotate
the drawing. Note that text is entered in paper units regardless of the sheet
scale.

The following symbol sets are provided to aid in production drafting.

Content Description

Geometric
Dimensioning and
Tolerancing (GD&T)
Symbols

Datum and feature control frames are
provided according to the ANSI Y14.5 or
ISO standard. Components of each frame are
provided as symbols with appropriate drag
points to fit into the frames.

Weld Symbols The weld reference line and components are
provided according to the American Welding
Society (AWS) or ISO standard.
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Plot Plan Templates Overview
You use these precision templates to produce plot plan and equipment layout
drawings.

• Plot Plan (Imperial) Template—This template has imperial units in decimal
inches, ANSI sheet sizes and borders.

• Plot Plan (Metric) Template—This template has metric units in millim eters,
ISO sheet sizes and borders, and implements the ISO dimensioning.

The DIN, BSI, and JIS dimensioning standards are also available in these two
templates. When you open these templates, the Draw toolbar appears, containing
tools to help you create precision drawings.

Plot Plan Workflow
You can draw plot plans associatively or non-associatively. The default behavior
is non-associative. To draw the plot plan associatively, set Maintain Relationships
on.

1. Set up the sheet.

Select an appropriate sheet size. The default sheet scale is 1 in:100 ft. for
imperial and 1mm:1000mm for metric.

2. Sketch the layout.

Draw the geometry for roads, buildings or equipment, using the tools from
the Draw toolbar and SmartSketch Settings. As you draw, relationships are
established that capture your design intent. As an example, with Maintain
Relationships set on, the software remembers when you draw a line
horizontally, vertically, or parallel to another line and maintains that
information when you modify the drawing.

3. Drag any symbols that are needed for the drawing.

You can place symbols precisely, relative to other components using PinPoint
or the precision Move command.

4. Dimension the part.

Use SmartDimension and the other dimensioning tools to dimension the
layout. If Maintain Relationships is set on, these dimensions are driving
dimensions that can be changed to iterate your design. Redundant dimensions
are shown through the driven elements.

5. Finish the drawing.
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Select individual dimensions and change the values to iterate your design.

The following symbol sets aid in construction of plot plan drawings.

Content Description

Plot Plan Assorted symbols to aid in the construction of Plot Plans.
Symbols include direction arrow, buildings, vessels,
tanks, vehicles, and others. Some of the symbols are
parametric and can be changed in the content explorer.
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Process Block Diagramming Templates
Overview

You use these templates to produce process block diagrams.

• Imperial Template—This template has imperial units in decimal inches,
ANSI sheet sizes, ANSI dimensioning and ANSI text.

• Metric Template—This template has metric units in mil limeters, ISO sheet
sizes, ISO dimensioning, and ISO text.

Basic Diagramming symbols are available in the Symbol Explorer for these two
templates. The Schematic toolbar containing tools to create diagrams appears on
the left of the drawing window.

Setting Up a Process Block Diagram

Tip You can create block diagrams with Maintain Relationships set on or off. It is
suggested that you accept the default, Maintain Relationships set off.

1. Set up the sheet.

Choose an appropriate sheet size and scale that allow enough paper space to
draw. The default scale is 1:1.

2. Prepare to draw.

Set the drawing aids to your preferences. Use the SmartSketch Settings, Grid
Display, and Grid Snap commands. For more grid options, click the View tab
on the Options dialog box to set the grid style to either dynamic or static, and
set the static grid to the preferred grid spacing.

• These settings provide visual feedback to you to improve the workflow
while you draw. To create clean diagrams, use Grid Snap with a static
grid displayed.

• Placing symbols and connectors on a static grid produces high quali ty
results.

• You can set grid display and snap by right clicking.

Drawing a Simple Diagram
1. Drag symbols from the Symbol Explorer.

2. Use the Connector command to connect symbols.
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3. Double-click each symbol to add text.

Drawing an Optimal Diagram
1. Place basic diagramming symbols by using the pointer to drag from the

Symbol Explorer.

Place multiple copies of a symbol by using the right mouse button to drag and
by selecting the Stamp Here option.

While dragging a symbol for placement, use the left/right arrow keys on the
keyboard to rotate the symbol dynamically before placement. Use the
up/down arrow keys to select different drag points on the symbol before
placement.

If you press the Alt key during symbol placement, the alignment indicators
are temporarily disabled, allowing symbol placement with grid snap or visual
alignment.

2. Connect the symbols by using the Connector command.

When you draw a connector that is not straight, you should set Clearance: to
the minimum distance from the symbol so that the first turn in the connector
appears.

When you draw a connector to a symbol, approach the symbol from the
direction you want the connector placed. As the pointer intent zone nears the
symbol, suggested targets for the connector appear.

The connector end point can be located on a target or any other symbol
geometry. If you press the Alt key while drawing a connector, the alignment
indicators are temporarily be disabled, allowing the connector to be drawn
with or without grid snap.

3. Double-click symbols to place text in the center of the symbol.

The active text settings in the file are used. To highlight existing text for
properties editing or moving, pause the pointer over text until the PickQuick
indicator appears.

Then click and select the numbered box that represents the text. Right-click
on the highlighted text to edit properties.

To move the highlighted text, click the green lock to unlock. Then with the
pointer drag the text to a new position. Note that text is entered in paper units
regardless of the sheet scale.

4. Finish the diagram.
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Use fills and modify the elements in symbols and connectors to enhance the
drawing.

The following symbol sets aid in drawing diagrams.

Content Description

Process Block
Diagrams

Common Basic diagramming symbols. You can
double-click these symbols to place text. These
symbols also have special behaviors for enhanced
placement and modification.
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Network Diagram Templates Overview
You use these templates to produce network diagrams.

• Imperial Template—This template has imperial units in decimal inches,
ANSI sheet sizes, ANSI dimensioning, and ANSI text.

• Metric Template—This template has metric units in millimeters, ISO sheet
sizes, ISO dimensioning, and ISO text.

Network Diagram symbols are available in the Symbol Explorer for these
templates. The Schematic toolbar containing tools to create network diagrams
appears on the left of the drawing window.

Network Diagram Workflow

Tip  You can create network diagrams with Maintain Relationships set on or off.

1. Set up the sheet.

Select an appropriate sheet size. The network symbols are accurately scaled
to 1/10th of their true size so you should leave the sheet scale at 1:1, the
default.

2. Prepare to draw.

Set the drawing aids to your preferences. Use the SmartSketch Settings, Grid
Display, and Grid Snap commands. For more grid options click the View tab
after you click Options on the Tools menu to set the grid style to either
dynamic or static. Set the static grid to the preferred grid spacing.

• These settings provide visual feedback to you to improve the workflow
while you draw.

Simple Network Diagram
1. Drag symbols from the Symbol Explorer.

2. Use the Connector command to connect symbols.

3. Double-click each symbol to add text.

Optimal Network Diagram
1. Place network diagram symbols by dragging from the Symbol Explorer.
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While dragging a symbol, use the left/right arrow keys on the keyboard to
rotate the symbol dynamically before placement. Use the up/down arrow keys
to select different drag points on the symbol before placement.

If you press the Alt key during symbol placement, the alignment indicators
are temporarily disabled, allowing symbol placement with grid snap or visual
alignment.

You can use two methods to place multiple copies of the same symbol:

• Holding down the right mouse button, drag the symbol into the template.
When you release the right mouse button to place the symbol, you are
prompted with two options. Click Stamp Here, and use the left mouse
button to place multiple copies of the symbol.

• Press the Ctrl key on the keyboard as you drag in a symbol with the left
mouse button. Place the first instance of the symbol while holding down
the Ctrl key. Once you have placed the first symbol, you can release the
Ctrl key and use the left mouse button to place multiple copies of the
symbol.

Some network symbols mount into the rack or chassis symbols when you
drag the symbol into a rack or chassis. When you pause over a drop point in a
chassis or rack, a tool tip appears; for example, Attach Module.

When you move a symbol, all associated symbols follow. To independently
move an associated symbol, select the symbol and click the green lock. This
frees the symbol from the element. A symbol is not associated to an element
if a green lock is not displayed when you select the symbol.

2. Add attributes to the network symbols by selecting the symbol and editing
fields in the Attribute Viewer.

3. Connect the symbols by using the Connector command or by dragging in
Cable symbols and then connecting the endpoints to network symbols. The
result is a symbolized connector with attribution.

When drawing connectors, you should set Clearance. Type the minimum
distance from the symbols that you would like the first turn in the connectors
to occur. This action allows you to control the visual consistency of
connectors that make right-angle turns just before they attach to a symbol.

When you draw a connector to a symbol, approach the symbol from the
direction you want the connector placed. As the pointer intent zone nears the
symbol, suggested targets for the connector appear. The connector end point
can be placed on a target or any of the symbol vector geometry. If you press
the Alt key while drawing a connector, the diagonal mode is temporarily
invoked and the alignment indicators are temporarily disabled.
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Note the connect points display a tool tip when the connector end point is
drawn or modified over a port on the network symbol.

You can edit attribute information on the connector and the network symbols
in the Attribute Viewer.

Smart Labels are provided for network symbols and cables. These Smart
Labels appear in the Symbol Explorer in the network symbol directories.
When you drag a network Smart Label over the drag point (usually the lower
left corner) of a network symbol, the label associates to the symbol and
accesses the symbol attribute information.

The description attribute data is displayed in the label. The cable labels
display the type and the speed-type of the cable.

4. Place text.

Double-click on the symbols to place text below the symbol or connector.
The active text settings in the file are used.

Right click on text to edit properties.

To move the text, select and highlight the text.

Click the green lock to unlock; then with the pointer, drag the text to a new
position. Note that text is entered in paper units regardless of the sheet scale.

5. Report on the network diagram.

Drag a report from the Symbol Explorer on to the sheet and follow the
instructions. An Excel spreadsheet is updated from the attributes of all the
network symbols in the file.

The following symbol sets aid in drawing diagrams.

Content Description

\Program Files\SmartSketch
\Symbols\Diagramming
\Network Diagram

Network diagram symbols that include
Cables, Chassis, Cards, Modules, Input-
Output Devices, Intelligent Network
Devices, Network Accessories, Non-
intelligent Network Devices, Physical
Plant, and Servers and Storage devices.
These symbols have attribution and
special behaviors for enhanced placement
and modification.
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Technical Drawing Templates Overview
You use these templates to produce technical drawings, sketches, and
illustrations.

• Imperial Template—This template has imperial units in decimal inches,
ANSI sheet sizes, ANSI dimensioning and ANSI text.

• Metric Template—This template has metric units in millimeters, ISO sheet
sizes, ISO dimensioning, and ISO text.

A set of simple drawing elements is also available in the Symbol Explorer for
these templates. The Draw toolbar containing tools to create precision drawings
appears on the left of the drawing window.

Drawing/Sketching Workflow

Tip  You can create technical drawings with Maintain Relationships set on or off.

1. Set up the sheet.

Select an appropriate sheet size and scale that allow you to enough paper
space to draw. The default scale is 1:1.

2. Draw elements.

Use the tools on the Draw toolbar and the SmartSketch Settings command or
drag symbols available in the Symbol Explorer.

Place multiple copies of symbols by using the right mouse button to drag and
by selecting the Stamp Here option, or by pressing the Ctrl key while
dragging a symbol from the Symbol Explorer.

If Maintain Relationships is set on, relationships between drawn objects are
established. As an example the system remembers when you draw a line
horizontally, vertically, or parallel to another line and maintains that
information when you modify the drawing.

You can use the Trim, Extend to Next, and Fillet commands to efficiently
modify drawn geometry.

3. Annotate the drawing.

Use text, dimensioning, and labels to annotate the drawing. Double-clicking
on any drawn object (except fills, dimensions, and leaders) creates an
associative text box. Note that text is entered in paper units regardless of the
sheet scale.

4. Finish the drawing.
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Use patterns and fills and modify the symbols to enhance the drawing.

The following symbol sets aid in production drafting.

Content Description

\ProgramFiles\
SmartSketch\Symbols\
Drawing

Commonly drawn elements such as line,
rectangle, ellipse, circle, and others are provided
to quickly begin a drawing. These symbols
become drawing elements when placed so they
are easily edited along with drawn elements.
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HVAC Templates Overview
You use these precision templates to produce HVAC designs and drawings
according to accepted industry standards.

• HVAC (Imperial)—This template has imperial units in feet and inches, ANSI
and Architectural sheet sizes and borders, and Architectural fill styles. It
provides symbols based on ASHRAE and ISO standards for residential and
commercial designs.

• HVAC (Metric)—This template has metric units in meters and centimeters,
ISO standard Architectural sheet sizes and borders, and Architectural fill
styles. It provides symbols based on ASHRAE and ISO standards for
residential and commercial designs.

The ANSI, DIN, BSI, ISO, and JIS dimensioning standards are also available in
these templates. When you open these templates, the Draw toolbar appears,
containing tools to help you create precision drawings.

Production Drafting Workflow for Double Line Duct
Layout
You can produce full sets of production drawings according to the AIA standards.

Tip  To produce a fairly complex production drawing, you should set Maintain
Relationships off.

1. Set up the sheet.

Select an appropriate sheet size and scale that allow you to draw the design.
The default scale is 1/4" = 1', which is appropriate for the average plan on a
D-Size sheet.

2. Reference a floor plan or open one.

Reference a floor plan by using the Object command on the Insert menu or by
dragging and dropping in the reference file. Or click File on the Open menu
to open (translate) the file.

Tip  Any MicroStation, AutoCAD, dxf, or igr document can be a reference
file.

3. Place duct symbols.

Using the Symbol Explorer, select the Double Line Duct folder from the
HVAC folder in the tree view. Drag the duct symbols over the reference file,
connecting one to another. Use the bold parameters that appear in the
Attribute Viewer to change the size of the duct.
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Tip  You can use two methods to place multiple copies of the same symbol:

• Holding down the right mouse button, drag the symbol into the template.
When you release the right mouse button to place the symbol, you are
prompted with two options. Click Stamp Here, and use the left mouse
button to place multiple copies of the symbol.

• Ctrl key on the keyboard as you drag in a symbol with the left mouse
button. Place the first instance of the symbol while holding down the Ctrl
key. Once you have placed the first symbol, you can release the Ctrl key
and use the left mouse button to place multiple copies of the symbol.

4. Annotate the drawing.

Use text and dimensioning commands to annotate the drawing. Text is
entered in paper units regardless of the sheet scale. To label double line ducts,
use the labels that automatically appear on symbols when you double-click
them.

5. Select a border or create one.

The HVAC templates are delivered with ten border sizes.

Select the borders with the Sheet Setup command on the File menu so that
they appear in the current design. On the Background tab, select the
background sheet to display with the working sheet. Use the Select Tool to
position the graphics appropriately in the border.

Note  The borders were designed from guidelines from the Construction
Specifications Institute (CSI).

The following symbol sets aid in production drafting.

Content Description

HVAC (Intergraph) HVAC symbols designed to best fit Double
Line Duct and Single Line Duct Layout
workflows. Several of these symbols are
designed with special behaviors and
parametric properties.

HVAC (ASHRAE) HVAC symbols designed to ASHRAE
standards.



Chapter 2 SmartSketch Getting Started Guide

50

Landscape Templates Overview
Use these precision templates to produce landscape designs and drawings
according to accepted industry standards.

• Landscape (Imperial)—This template has imperial units in feet and inches,
ANSI and architectural sheet sizes and borders, and architectural fill styles. It
provides symbols based AIA  standards for residential and commercial
designs.

• Landscape (Metric)—This template has metric units in meters and
centimeters, ISO standard architectural sheet sizes and borders, and
architectural fill styles. It provides symbols based on AIA standards for
residential and commercial designs.

The ANSI, DIN, BSI, ISO, and JIS dimensioning standards are also available in
these two templates. When you open these templates, the Draw toolbar appears,
containing tools to help you create precision drawings.

Production Drafting Workflow for Landscape
Designs
You can produce full sets of production drawings according to the AIA standards.

Tip  To produce a fairly complex production drawing, you should set Maintain
Relationships off.

1. Set up the sheet.

Choose an appropriate sheet size and scale for the design. The default scale is
¼ inches = 1 foot, which is appropriate for the average plan on a D Size sheet.

2. Reference a floor plan or open one.

Reference a floor plan by using the Object command on the Insert menu or by
dragging and dropping in the reference file. Or use the Open command on the
File menu to open (translate) the file.

Tip  Any MicroStation, AutoCAD, dxf, or igr document can be a reference
file.

3. Create a foot print.

If you reference the plan, using the drawing tools on the Draw tool bar, you
can trace the outer perimeter of the reference plan to create the outline shape
of the building. Either delete or move the reference file to a layer and turn it
off.
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4. Place symbols.

Drag the landscape symbols into the document in the appropriate positions.

You can use two methods to place multiple copies of the same symbol:

• Holding down the right mouse button, drag the symbol into the template.
When you release the right mouse button to place the symbol, you are
prompted with two options. Click Stamp Here, and use the left mouse
button to place multiple copies of the symbol.

• Ctrl key on the keyboard as you drag in a symbol with the left mouse
button. Place the first instance of the symbol while holding down the Ctrl
key. Once you have placed the first symbol, you can release the Ctrl key
and use the left mouse button to place multiple copies of the symbol.

5. Annotate the drawing

Use text and dimensioning to annotate the drawing. Text is entered in paper
units regardless of the sheet scale. To label landscape symbols, use the labels
that automatically appear on symbols when you double-click them.

6. Select a border or create one.

The Landscape templates are delivered with ten border sizes.

Select the borders with the Sheet Setup command so that they appear in the
current design. On the Background tab, select the background sheet to display
with the working sheet.

You should use the Select Tool to position the graphics appropriately in the
border.

Note  The borders were designed from guidelines from the Construction
Specifications Institute (CSI).

The following symbol sets aid in production drafting.

Content Description

Elevations Symbols Provide AIA and Intergraph standard
elevation symbols for commercial and
residential Landscape design.

Plan Symbols Provide AIA and Intergraph standard
plan symbols for commercial and
residential Landscape design.
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Flowchart Templates Overview
You use these templates to produce flowcharts and diagrams.

• Imperial Template—This template has imperial units in decimal inches,
ANSI sheet sizes, ANSI dimensioning and Arial text.

• Metric Template—This template has metric units in millimeters, ISO sheet
sizes, ISO dimensioning, and Arial text.

Flowchart, Audit, Dataflow, and TQM symbols are available in the Symbol
Explorer for these templates. The Schematic toolbar containing tools to create
flowcharts and diagrams appears on the left of the drawing window.

Setting Up a Flowchart

Tip  You can create flowcharts and diagrams with Maintain Relationships set on
or off.

1. Set up the sheet.

Select an appropriate sheet size and scale that allow enough paper space to
draw. The default scale is 1:1.

2. Prepare to draw.

Set the drawing aids to your preferences. Use the SmartSketch Settings, Grid
Display, and Grid Snap commands.

For more grid options, click the View tab after you click the Options
command on the Tools menu to set the grid style to either dynamic or static,
and set the static grid to the preferred grid spacing.

• These settings provide visual feedback to you to improve the workflow
while you draw. To create clean diagrams, use Grid Snap with a static
grid displayed.

• Placing symbols and connectors on a static grid produces high quality
results.

• You can set grid display and snap by right clicking.

Drawing a Simple Flowchart and Diagram
1. Drag symbols from the Symbol Explorer.

2. Use the Connector command to connect symbols.
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3. Double-click each symbol to add text.

Drawing an Optimal Flowchart and Diagram
1. Place flowchart and diagram symbols by dragging from the Symbol Explorer.

While dragging a symbol for placement, use the left/right arrow keys on the
keyboard to rotate the symbol dynamically before placement.

Use the up/down arrow keys to select different drag points on the symbol
before placement. If you press the Alt key during symbol placement, the
alignment indicators are temporarily disabled, allowing symbol placement
with grid snap or visual alignment.

You can use two methods to place multiple copies of the same symbol:

• Holding down the right mouse button, drag the symbol into the template.
When you release the right mouse button to place the symbol, you are
prompted with two options. Click Stamp Here, and use the left mouse
button to place multiple copies of the symbol.

• Press the Ctrl key on the keyboard as you drag in a symbol with the left
mouse button. Place the first instance of the symbol while holding down
the Ctrl key. Once you have placed the first symbol, you can release the
Ctrl key and use the left mouse button to place multiple copies of the
symbol.

2. Connect the symbols by using the Connector command.

When drawing connectors, you should set Clearance. Type the minimum
distance from the symbols that you would like the first turn in the connectors
to occur. This action allows you to control the visual consistency of
connectors that make right-angle turns just before they attach to a symbol.

When you draw a connector to a symbol, approach the symbol from the
direction you want the connector placed. As the pointer intent zone nears the
symbol, suggested targets for the connector appear.

The connector end point can be located on a target or any other symbol
geometry. If you press the Alt key while drawing a connector, the diagonal
drawing mode will be temporarily activated, allowing the connector to be
drawn at any angle with or without grid snap.

Double-click symbols to place text in the center of the symbols.

The active text settings in the file are used. To highlight existing text for
properties editing or moving, pause the pointer over text until the PickQuick
indicator appears.
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Then click and select the numbered box that represents the text. Right-click
on the highlighted text to edit properties. To move the highlighted text, click
the green lock to unlock.

Then with the pointer drag the text to a new position. Note that text is entered
in paper units regardless of the sheet scale.

3. Finish the diagram.

Use color to modify the symbols and connectors to enhance the drawing.

The following symbol sets are provided to aid in drawing diagrams.

Content Description

\Program Files\SmartSketch
\Symbols\Diagramming
\Flowchart

Flowchart, Audit, Dataflow, and TQM
symbols. You can double-click these symbols
to place text. These symbols also have special
behaviors for enhanced placement and
modification.
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Workflow Diagram Templates Overview
You use these templates to produce workflow diagrams.

• Imperial Template—This template has imperial units in decimal inches,
ANSI sheet sizes, ANSI dimensioning, and Arial text.

• Metric Template—This template has metric units in millimeters, ISO sheet
sizes, ISO dimensioning, and Arial text.

Work flow symbols are available in the Symbol Explorer for these templates. The
Schematic toolbar containing tools to create workflow diagrams appears on the
left of the drawing window.

Schematic Workflow

Tip  You can create workflow diagrams with Maintain Relationships set on or
off.

1. Set up the sheet.

Select an appropriate sheet size and scale that allow enough paper space to
draw. The default scale is 1:1.

2. Prepare to draw.

Set the drawing aids to your preferences. Use the SmartSketch Settings, Grid
Display, and Grid Snap commands.

For more grid settings, click the View tab after you click the Options
command on the Tools menu to set the grid style to either dynamic or static,
and set the static grid to the preferred grid spacing.

• These settings provide visual feedback to you to improve the workflow
while you draw. To create clean diagrams, use Grid Snap with a static
grid displayed.

• Placing symbols and connectors on a static grid produces high quality
results.

• You can set grid display and snap by right clicking.

Drawing a Simple Workflow Diagram
1. Drag symbols from the Symbol Explorer.

2. Use the Connector command to connect symbols.



Chapter 2 SmartSketch Getting Started Guide

56

3. Double-click each symbol to add text.

Drawing an Optimal Workflow Diagram
1. Place symbols.

Place symbols by using the pointer to drag symbols from the Symbol
Explorer.

While dragging a symbol, use the left/right arrow keys on the keyboard to
rotate the symbol dynamically before placement.

Use the up/down arrow keys to select different drag points on the symbol
before placement.

If you press the Alt key during symbol placement, the alignment indicators
are temporarily disabled, allowing you to place a symbol using the Grid Snap
command or visual alignment.

You can use two methods to place multiple copies of the same symbol:

• Holding down the right mouse button, drag the symbol into the template.
When you release the right mouse button to place the symbol, you are
prompted with two options. Click Stamp Here, and use the left mouse
button to place multiple copies of the symbol.

• Press the Ctrl key on the keyboard as you drag in a symbol with the left
mouse button. Place the first instance of the symbol while holding down
the Ctrl key. Once you have placed the first symbol, you can release the
Ctrl key and use the left mouse button to place multiple copies of the
symbol.

2. Connect the symbols.

Use the Connector command. When you draw a connector that is not straight,
you should set Clearance on the ribbon bar to the minimum distance from the
symbol where the first turn in the connector occurs.

When you draw a connector to a symbol, approach the symbol from the
direction you want the connector placed. As the pointer intent zone nears the
symbol, suggested targets for the connector appear.

If you press the Alt key while drawing a connector, the diagonal mode is
temporarily invoked and the alignment indicators are temporarily disabled,
allowing the connector to be drawn with or without grid snap.

3. Place text.
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Double-click symbols to edit text labels at the bottom of the symbols. To
highlight existing text for properties editing or moving, pause the pointer over
text until the PickQuick indicator appears. Then click and select the
numbered box that represents the text. Right-click on the highlighted text to
edit properties.

To move the highlighted text, click the green lock to unlock. Move the text to
a new position. Note that text is entered in paper units regardless of the sheet
scale.

4. Finish the diagram.

Use color to modify the symbols and connectors to enhance the drawing.

The following symbol sets aid in drawing workflow diagrams.

Content Description

\Program Files\SmartSketch
\Symbols\Diagramming
\Workflow Diagram

Workflow Diagram symbols. These
symbols have special behaviors for
enhanced placement and modification.
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Organizational Chart Templates Overview
You use these templates to produce organizational charts.

• Imperial Template—This template has imperial units in decimal inches,
ANSI sheet sizes, ANSI dimensioning, and Arial text.

• Metric Template—This template has metric units in mil limeters, ISO sheet
sizes, ISO dimensioning, and Arial text.

Org Chart symbols are available in the Symbol Explorer for these templates. The
Schematic toolbar containing tools to create organizational charts appears on the
left of the drawing window.

Automated Organizational Chart Creation
1. Load the add-in.

On the Main toolbar, click the Add-Ins command on the Tools menu and
check the box for Org Chart Wizard.

2. Launch The Wizard of Org.

On the Main toolbar, click the Org Chart Wizard command on the Tools
menu and follow the instructions to continue.

This wizard creates an organizational chart with or without personnel data.
The completion of the wizard results in a new sheet added to the open file
containing your chart. You can edit the resulting symbols and connectors
interactively as if the chart had been drawn manually.

Organizational Chart Workflow

Tip  You can create organizational charts with Maintain Relationships set on or
off.

1. Set up the sheet.

Select an appropriate sheet size and scale that allow enough paper space to
draw. The default scale is 1:1.

2. Prepare to draw.

Set the drawing aids to your preferences. Use the SmartSketch Settings, Grid
Display, and Grid Snap commands. For more grid options, click the View tab
after you click the Options command on the Tools menu to set the grid style
to either dynamic or static, and set the static grid to the preferred grid spacing.
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• These settings provide visual feedback to you to improve the workflow
while you draw. To create clean diagrams, use Grid Snap with a static
grid displayed.

• Placing symbols and connectors on a static grid produces high quality
results.

• You can set grid display and snap by right clicking.

Simple Workflow Diagram
1. Drag symbols from the Symbol Explorer.

2. Use the Connector command to connect symbols.

3. Double-click each symbol to add text.

Optimal Workflow Diagram
1. Place Org Chart symbols by dragging them from the Symbol Explorer.

While dragging a symbol for placement, use the left/right arrow keys on the
keyboard to rotate the symbol dynamically before placement. Use the
up/down arrow keys to select different drag points on the symbol before
placement.

If you press the Alt key during symbol placement, the alignment indicators
are temporarily disabled, allowing symbol placement with grid snap or visual
alignment.

These symbols automatically expand to the size of the text. You can also size
them by using the yellow handles.

Tip  You can use two methods to place multiple copies of the same symbol:

• Holding down the right mouse button, drag the symbol into the template.
When you release the right mouse button to place the symbol, you are
prompted with two options. Click Stamp Here, and use the left mouse
button to place multiple copies of the symbol.

• Press the Ctrl key on the keyboard as you drag in a symbol with the left
mouse button. Place the first instance of the symbol while holding down
the Ctrl key. Once you have placed the first symbol, you can release the
Ctrl key and use the left mouse button to place multiple copies of the
symbol.

2. Connect the symbols by using the Connector command.
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When you draw a connector that is not straight, you should set Clearance: to
the minimum distance from the symbol where the first turn in the connector
appears.

When you draw a connector to a symbol, approach the symbol from the
direction you want the connector placed. As the pointer intent zone nears the
symbol, suggested targets for the connector appear.

The connector end point can be located on a target or any other symbol
geometry. If you press the Alt key while drawing a connector, the diagonal
mode is temporarily invoked and the alignment indicators are temporarily
disabled, allowing the connector to be drawn with or without grid snap.

3. Double-click symbols to place text in the center of the symbol.

The active text settings in the file are used. To highlight existing text for
editing properties, pause the pointer over text until the PickQuick indicator
appears.

Then click and select the numbered box that represents the text. Right-click
the highlighted text to edit properties.

Note that text is entered in paper units regardless of the sheet scale.

4. Finish the organizational chart.

Use color to modify the symbols and use connectors to enhance the drawing.

The following symbol sets aid in drawing organizational charts.

Content Description

\Program Files\SmartSketch
\Symbols\Diagramming
\Org Chart

Organizational Chart symbols. You can
double-click these symbols to place text. These
symbols also have special behaviors for
enhanced placement and modification.
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PFD and P&ID Templates Overview
You use these schematic templates to produce process flow diagrams according
to accepted industry standards.

• PFD (Intergraph) Template—This template is set up to be a schematic
template to create process flow diagrams. The default symbol set is a subset
of the Intergraph SP2D symbol set. The delivered set draws most PFDs. If
you need other Intergraph symbols, you can copy them from the P&ID
(Intergraph) symbol set.

• PFD ANSI Template—This template is set up to be a schematic template to
create process flow diagrams based on ANSI Process Flow Standards. ASA
Z32.2.3-1949.

• PFD ISO Template—This template is set up to be a schematic template to
create process flow diagrams based on ISO Process Flow Standards. (General
Rules—Flow Diagrams for Process Plants - ISO 10628)

• P&ID (Intergraph) Template—This template is set up to be a schematic
template to create process flow diagrams and P&ID diagrams. The symbol set
is the Intergraph SP2D symbol set, consisting of approximately 1000
symbols. You can reconfigure the symbol locations and directories to your
specification for easy location.

PFD and P&ID Workflow

Tip  You should create schematic drawings with Maintain Relationships cleared.

1. Set up the sheet.

Select an appropriate sheet size and scale that allow you to draw the
schematic drawing. The default scale is 1:1, which is appropriate for the
symbol sizes.

2. Place symbols.

Drag in the major components of the PFD and place them at locations on the
sheet.

These components usually include vessels, pumps, and heat exchangers.

You can use two methods to place multiple copies of the same symbol:

• Holding down the right mouse button, drag the symbol into the template.
When you release the right mouse button to place the symbol, you are
prompted with two options. Click Stamp Here, and use the left mouse
button to place multiple copies of the symbol.



Chapter 2 SmartSketch Getting Started Guide

62

• Press the Ctrl key on the keyboard as you drag in a symbol with the left
mouse button. Place the first instance of the symbol while holding down
the Ctrl key. Once you have placed the first symbol, you can release the
Ctrl key and use the left mouse button to place multiple copies of the
symbol.

3. Enter attribute information for the individual components.

To enter data in the attributes, select the symbol and add the information in
the Attribute Viewer.

4. Attach nozzles to major equipment.

Nozzles are automatically aligned and can be placed anywhere on the major
equipment.

5. From the Schematic toolbar select the Connector command.

Connect the major components together at the locations you want on each
symbol.

• Each symbol has predefined connect points; however, the connector can
connect to any graphic location on the symbol.

• The connector routes itself away from the original symbol and toward the
target symbol.

• You can attach connectors to connectors.

• A connector being placed or modified can have its starting or ending
point anywhere along another connector.

6. Set connector flow direction at any time.

There are two methods to set the flow direction:

• When you place the connector, you can use the options on the connector
toolbar to select the starting and ending terminator for the connector.

• You can drag an arrowhead symbol from the browser and connect it to
the end of the connector.

7. Drag inline symbol components such as valves onto the connectors.

The valve symbols have automated aligning turned on. This means that the
valve automatically aligns to the direction of the connector.

Note that the valve is placed on top of the connector and hides the portion of
the connector that the valve covers.
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8. To associate a text box with a symbol that does not already have associated
text.

Double-click the symbol.

Then, type in text.

• Moving the symbol causes the text to move and maintain its relative
location to the symbol.

• If a symbol already has associated text, double-clicking the symbol
allows you to edit the text.

9. After you have placed components and connectors, you can modify the
symbols and/or connectors by selecting and dragging them to a new location.

• You can select and drag multiple symbols to a new location.

• You can select and modify single connectors.

• You can adjust segments of connectors to new locations or move and
reattach endpoints.

The following symbol sets aid in schematic drawings of PFDs and P&IDs.

Content Description

P&ID (Intergraph) Intergraph Symbol set containing
symbols needed for creating PFDs,
P&IDs, and Material Handling
drawings.

PFD (Intergraph) Symbol set that is a subset of the
P&ID (Intergraph) set. Symbols are
adequate to create most PFDs. Other
symbols from P&ID or other symbol
sets can be copied to the PFD
directory and are displayed for
selection.

PFD (ISO Standard) Symbol set based on the ISO 10628
standard. General rules for flow
diagrams for process plants.

PFD (ANSI) Symbol set based on ASA Z32.2.3-
1949

ASME Y32.2.2.3 Graphical symbols
for pipe fittings, valves and piping.
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Ortho Piping Template Overview
You use this precision template to produce orthographic piping drawings, using
common sized components and pipes.

• Ortho Piping Template—This template has imperial units in feet and inches,
with a precision of 1/32”. The sheet scale is set to 1/2” = 1’.

ANSI, ISO, DIN, BSI, and JIS dimensioning standards are available in the
template. The default dimension type is ANSI. When you open this template, the
Draw toolbar appears, containing tools to help you create precision drawings.

Ortho Piping Workflow 1 (Small Layouts)
• You can create small layouts with Maintain Relationships set on.

• Select Midpoint from the SmartSketch Settings options.

1. Set up the sheet.

Select an appropriate sheet size. The default scale is 1/2” = 1’.

2. From the Symbol Explorer, select the size of piping to be placed. A list of
folders containing appropriate components for that size of pipe is displayed.

3. Place a line.

On the Draw toolbar, click Line/Arc Continuous. On the ribbon bar, select the
appropriate line style. Click to place the line.

4. Drag one of the piping components into the document close to the end of the
pipe where it is placed. Example 150# Gate Valve with flanges. If the
orientation of the valve is not correct relative to the pipe, use the left or right
arrow keys to rotate as needed. Click the symbol.

5. To display the Relationships toolbar, click  Relationships on the Main toolbar

6. On the Relationships toolbar, click Connect.

7. Identify the center on one end of the valve as the first point to connect to. You
can see the midpoint indicator as the pointer moves over the center of the end
of the valve.

8. Identify the end of the line placed previously as the other end to connect. The
valve moves to the end of the pipe. If Maintain Relationships is set on, the
valve remains connected when modifi cations are made.

9. Place another line from the other end of the valve. Select the midpoint of the
end of the valve from which to start. Place the line an approximate length.
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10. From the 4” Els directory select the 90 degree elbow and drag it into the fi le.
Use the rotate keys to rotate to a correct orientation. Connect the midpoint of
the elbow to the end point of the 4”  line.

11. Repeat the process as needed until the layout is complete.

12. Place dimensions between key components of the layout.

Note  Workflow method 1 is recommended for small layouts because the
constraints needed to handle a large piping layout may make the system too slow
for practical use.

Ortho Piping Workflow 2 (Large Layouts)
• You should create large piping layouts with Maintain Relationships set off.

• Be sure to select Midpoint from the SmartSketch Settings options.

1. To set up the sheet, select an appropriate sheet size and scale that allow you
to draw the piping layout. The default scale is 1/2” = 1’.

2. From the Symbol Explorer, select the size of components to be placed. A list
of folders containing appropriate components for that size of pipe is
displayed.

3. On the Draw toolbar, click Line/Arc Continuous. Draw a single line,
centerline, layout of the piping system to be drawn. Placing centerlines on a
different layer is recommended.

4. From the Symbol Explorer, select the proper sized components to be placed,
and drag the components onto the line.

5. When the components are placed in their proper locations, turn off the
centerline layer.

6. Select the Place Doubleline command, a flyout on the Line/Arc Continuous
command. Set the placement option on the toolbar to Center Primary Line;
then select a width.

7. Use relationship indicators to locate the midpoint of one of the components,
and click the left mouse button. Use midpoint to locate the end of the next
component that has been placed, and click the right mouse button. A
doubleline representing the size of the pipe is placed.

8. Continue connecting components in this manner until all components are
connected.
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Note  To show pipes crossing, the doubleline representing the pipe on top can be
filled or patterned with a blank color. The pipe that is to be displayed below can
be selected and pushed to the bottom in the display. To select and push the pipe to
the bottom, click Send to Back on the Change toolbar.

Tip  You can place pipes using the method in Workflow 1 with the Line/Arc
Continuous command instead of using the Place Doubleline command.

The following symbol sets aid in Ortho Piping layouts.

Content Description

Orthographic Piping
Symbols

Sizes 1,2,3,4,6,8,10,12
Inches

Each Size contains the following:

150# Valves

300# Valves

Actuators

Annotation

Els

Olet

Reducers

Welds

1 and 2 Inch sizes also include 600#
and 800#  valves.
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Electrical Templates Overview
You use these schematic templates to produce electrical drawings according to
accepted industry standards.

• Imperial Template—This template is defined with ANSI sheet sizes and
borders. The default sheet size is C with a 1:1 scale.

• Metric Template—This template is defined with ISO sheet sizes and borders.
The default sheet size is A1 with a 1:1 scale.

Both templates point to the electrical symbol sets. The electrical symbols include
main classifications of the following: Circuit Protectors, Contacts and Relays,
Electron Tubes, Fundamental Items, High Voltage, Logic Gates, Qualifying
Symbols, Rotating Mach, Semiconductors, Signaling and Readout Devices,
Switches, Terminals and Connectors, Transformers and Inductors, and
Transmission Path.

Tip  You should design schematic drawings with Maintain Relationships set off
(default setting).

Electrical Workflow 1
1. Set up the sheet.

Select an appropriate sheet size and scale.

2. Place an initial symbol correctly rotated.

3. Route a connector from that symbol to form a rough outline of the circuit.

4. From the Symbol Explorer, select the type of symbol or component needed,
and drag the component onto the sheet and over the connector.

The connector is highlighted when the pointer moves over the element. Most
of the components automatically align to the connector.

Drop the symbol, and it is placed, associated to the connector. Or, if the
orientation of the symbol is not correct, use the left or right arrows to rotate
the symbol to a new orientation. When the symbol is dropped, it maintains the
orientation.

5. Enter any attribute information that you want in the Attribute Viewer.

When the information is changed in the viewer, the text information on the
symbol also changes. If you do not want the attribute text, you can select the
text box and delete text from the symbol.
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6. Continue adding or modifying connectors and adding components until the
circuit is complete.

Electrical Workflow 2
1. Set up the sheet.

Select an appropriate sheet size and scale.

2. From the Symbol Explorer, drag the component onto the sheet to the location
you want.

Or, if the orientation of the symbol is not correct, use the left or right arrows
to rotate the symbol to a new orientation. When the symbol is dropped, it
maintains the orientation.

3. Enter any attribute information that you want in the Attribute Viewer.

When the information is changed in the viewer, the text information on the
symbol also changes. If you do not want the attribute text, you can select the
text box and delete text from the symbol.

4. Continue dragging and dropping components as needed to complete the
circuit.

5. Using the Connector command, connect the individual components.

6. Continue adding components and connecting them together until the circuit is
complete.

Differences in Workflow 1 and 2
• Workflow 1 places the symbol or component on the connector or wire. It does

not break the wire. It only masks out the connector beneath it. In this case the
components are glued to the connector. To modify the circuit in such a case,
you move the connector, and the symbols follow it to the new location.

• Workflow 2 places a connector or wire between the components that are
placed. Workflow 2 is more of a real-world flow. In this case, you can select
and move the components, and the connector or wires move to adjust to the
new component location.

• You can combine the workflows. You must, however, remember which is the
parent and which is the child when you combine the two.
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The following symbol sets aid in electrical schematic creation.

Content Description

Electrical Symbols Circuit Protectors
Contacts and Relays
Electron Tubes
Fundamental Items
High Voltage Items
Logic Gates
Qualifying Symbols
Rotating Mach & Comp Assembly
Semiconductors
      Diodes
     Thyristors
     Transistors
Signaling & Readout Devices
Switches
Terminal & Connectors
Transformers & Inductors
Transmission Path
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Control Loop Template Overview
You use this schematic template to produce control loop diagrams using
Intergraph supplied symbols according to accepted industry standards.

• Imperial Template—This template defaults to a B size sheet. The sheet
background consists of two sections divided into two categories. The main
sections are Field and I/O Building.

• The Field section is divided into Instrument and Junction Box categories.

• The I/O Building is divided into Termination Rack and I/O Cabinet
categories.

Tip  If you need a different configuration for the background, click Background
Sheets on the View menu, and select a sheet and modify as needed. Then click
Working Sheets on the View menu. The working sheet displays the changes that
were made in the background sheet.

Control Loop Workflow

Tip  You should create schematic drawings with Maintain Relationships cleared.

1. Set up the sheet.

Select an appropriate sheet size. The default sheet size is B with a scale of
1:1.

2. Place symbols.

The Symbol Explorer defaults to the Control Loop symbol set. The set is
divided into logical components such as controllers, recorder, terminal strips,
transmitters and others. Select a component and drag it to the location you
want.

Tip  A typical configuration might be as follows: Field—Instrument—
Thermocouple, Junction Box- 3 Wire Terminal Strip; I/O Building—
Termination Rack—3 Wire Terminal Strip w/ground and I/O Cabinet—
Electrical Recorder.

3. Click Connector and connect the components together as you want.

Connect points have been placed on each component where typical
connections can be made.

4. Edit attributes.
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Some components have attributes associated with them that change the text
associated with them. Select the component, and change the attributes you
want to change in the Symbol Explorer. The text labels are updated to display
the input values.

The following symbol sets to aid in control loop diagramming.

Content Description

Control Loop
Diagrams

Control Loop symbols categorized
into the following groupings:
Controllers, Flow Elements,
Indicators, Positioners, Recorders,
Switches, Temperature Elements,
Terminal Strips, Transmitters and
Valves.
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Atlas Mapping Templates Overview
You use these templates to produce maps.

• Imperial Template—This template has imperial units in decimal inches,
ANSI sheet sizes, ANSI dimensioning, and Arial text.

• Metric Template—This template has metric units in millimeters, ISO sheet
sizes, ISO dimensioning, and Arial text.

Atlas Map symbols for the United States are available in the Symbol Explorer for
these templates. The Draw toolbar containing tools to create maps appears on the
left of the drawing window.

Mapping Workflow

Tip  You can create maps with Maintain Relationships set on or off.

1. Set up the sheet.

Select an appropriate sheet size. The default scale is 1:1.

2. Draw the map.

Place map symbols by using the mouse to drag from the Symbol Explorer.
While dragging a symbol for placement, use the left/right arrow keys on the
keyboard to rotate the symbol dynamically before placement.

Use the up/down arrow keys to select different drag points on the symbol
before placement. If you press the Alt key during symbol placement, the
alignment indicators are temporarily disabled, allowing symbol placement
with grid snap or visual alignment.

You can use two methods to place multiple copies of the same symbol:

• Holding down the right mouse button, drag the symbol into the template.
When you release the right mouse button to place the symbol, you are
prompted with two options. Click Stamp Here, and use the left mouse
button to place multiple copies of the symbol.

• Ctrl key on the keyboard as you drag in a symbol with the left mouse
button. Place the first instance of the symbol while holding down the Ctrl
key. Once you have placed the first symbol, you can release the Ctrl key
and use the left mouse button to place multiple copies of the symbol.

When you drag and pause a symbol over an existing map symbol drop point,
a tool tip appears, identifying the state to be placed adjacently. Dropping the
symbol on the drop point ensures that the state boundaries match perfectly.



Industry Solutions Chapter 2

73

3. Place text.

Double-click symbols to place text in the center of the symbol. The active
text settings in the file are used.

To highlight existing text for properties editing or moving, pause the pointer
over text until the PickQuick indicator appears. Then click and select the
numbered box that represents the text. Right-click on the highlighted text to
edit properties.

To move the highlighted text, click the green lock to unlock. Move the text to
a new position. Note that text is entered in paper units regardless of the sheet
scale.

4. Finish the drawing.

Finish the map by drawing details, adding text, or modifying the symbols to
enhance the map.

The following symbol sets aid in drawing maps.

Content Description

\Program Files\SmartSketch
\Symbols\Diagramming
\Atlas Map\US States

United States Map symbols. These
symbols have drag points as well as
special behaviors for enhanced
placement and modification.
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Directional Mapping Templates Overview
You use these templates to produce directional maps.

• Imperial Template—This template has imperial units in decimal inches,
ANSI sheet sizes, ANSI dimensioning, and Arial text.

• Metric Template—This template has metric units in millimeters, ISO sheet
sizes, ISO dimensioning, and Arial text.

Directional Map symbols are available in the Symbol Explorer for these
templates. The Draw toolbar containing tools to create maps appears on the left of
the drawing window.

Directional Mapping Workflow

Tip  You can create maps with Maintain Relationships set on or off.

1. Set up the sheet.

Select an appropriate sheet size. The default scale is 1:1.

2. Draw a directional map.

Draw transportation routes, first using the Line/Arc Continuous command or
the Curve command. Select the command from the Draw toolbar. Select a
linestyle such as Rural Road or Railroad.

• When you use the Line/Arc Continuous command, click A on the
keyboard to draw an arc. To turn line mode back on, click L on the
keyboard.

• When you use the Curve command, press the left mouse button as you
draw.

• You can label transportation routes by double-clicking the line and typing
the name of the road or railroad. The text automatically aligns to linear
elements.

3. Place symbols.

Place directional map symbols to represent landmarks by dragging from the
Symbol Explorer.

While dragging a symbol, use the left/right arrow keys on the keyboard to
rotate the symbol dynamically before placement. Use the up/down arrow keys
to select different drag points on the symbol before placement. If you press
the Alt key during symbol placement, the alignment indicators are
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temporarily disabled, allowing symbol placement with grid snap or visual
alignment.

You can use two methods to place multiple copies of the same symbol:

• Holding down the right mouse button, drag the symbol into the template.
When you release the right mouse button to place the symbol, you are
prompted with two options. Click Stamp Here, and use the left mouse
button to place multiple copies of the symbol.

• Press the Ctrl key on the keyboard as you drag in a symbol with the left
mouse button. Place the first instance of the symbol while holding down
the Ctrl key. Once you have placed the first symbol, you can release the
Ctrl key and use the left mouse button to place multiple copies of the
symbol.

4. Place text.

Double-click symbols or lines to place text.

The active text settings in the file are used. To highlight existing text for
repositioning or editing text properties or moving properties, pause the
pointer over text until the PickQuick indicator appears. Then click and select
the numbered box that represents the text.

Right-click the highlighted text to edit properties.

To move the highlighted text, click the green lock to unlock. Move the text to
a new position. Note that text is entered in paper units regardless of the sheet
scale.

5. Finish the map.

Draw details and modify the color or linestyles of the symbols to enhance the
map.

The following symbol sets aid in drawing directional maps.

Content Description

\Program Files\SmartSketch
\Symbols\Diagramming
\Directional Map

Directional Map symbols have special
behaviors for enhanced placement and
modification.



Chapter 2 SmartSketch Getting Started Guide

76

Office Layout Templates Overview
You use these templates to produce Office Layout drawings.

• Imperial Template—This template has imperial units in decimal inches,
ANSI sheet sizes, ASA dimensioning, and Architectural text.

• Metric Template—This template has metric units in millimeters, ISO sheet
sizes, ISO dimensioning, and ISO text.

Office layout symbols are available in the Symbol Explorer for these templates.
The Draw toolbar containing tools to create office layout drawings appears on the
left of the drawing window.

Office Layout Workflow

Tip  You should create office layout drawings with Maintain Relationships set
on.

1. Set up the sheet.

Select an appropriate sheet size and scale that allow you to draw the design.
The default scale is 1/4" = 1' for the Imperial template and 1:50 for the Metric
template.

2. Prepare to draw.

Set the drawing aids to your preferences. Use the SmartSketch Settings, Grid
Display, and Grid Snap commands.

For more grid options, click the View tab on the Options dialog box to set the
grid style to either dynamic or static, and set the static grid to the preferred
grid spacing.

• These settings provide visual feedback to you to improve the workflow
while you draw. To create clean diagrams, use Grid Snap with a static
grid displayed.

• Placing symbols and connectors on a static grid produces high quality
results.

• You can set grid display and snap by right clicking.

Note  You can begin by drawing the office walls or by referencing or
opening a floor plan drawing.
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3. Draw walls.

Click the Place Doubleline command on the Draw toolbar and set the
thickness of the walls to be drawn in the ribbon bar.

Click the appropriate button on the ribbon bar to indicate whether you draw
from the center of the wall or one of the edges (primary line buttons).

Draw the walls first.

Next use the Trim, Trim Corner, and Extend to Next commands for any
intersection cleanup.

• If you press the Alt key while drawing, the alignment indicators are
temporarily disabled.

• When you draw the walls, you may want to select a neutral gray for the
line color. After you draw the walls, you can avoid cleaning the
intersections by color filling the walls with a solid fill of the same neutral
gray color.

• Use the door and window symbols to complete the floor plan. These
symbols automatically align to the wall and can be mirrored, scaled and
rotated after placement.

Note  You can also use the Place Doubleline command for drawing office
partitions, along-wall working surfaces, counter tops, work benches,
stockroom shelves, custom bookcases, custom desks, and cat walks. If you
press and hold the Shift key when you draw with the Place Doubleline
command, the end caps do not automatically merge into another section of
doubleline. This feature is useful for drawing partitions perpendicular to
walls. You can use the Fillet command to round the corners of counter tops.

4. Reference or open an existing floor plan.

Reference a floor plan by using Object command on the Insert menu or by
dragging the existing file into the drawing window. Or click the Open
command on the File menu to open an existing floor plan file.

Tip  You can reference or open any MicroStation, AutoCAD, dxf, or igr
document.

5. Place office layout symbols.

Drag symbols from the Symbol Explorer. While dragging a symbol, use the
left/right arrow keys on the keyboard to rotate the symbol dynamically before
placement. Use the up/down arrow keys to select different drag points on the
symbol before placement.
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If you press the Alt key during symbol placement, the alignment indicators
are temporarily disabled, allowing symbol placement with grid snap or visual
alignment.

Office Layout symbols can be physically associated to walls or other
symbols. When you move a symbol or a wall, all associated symbols follow.

To independently move an associated symbol, select the symbol and click the
green lock to unlock the association. A symbol is not associated if a green
lock is not displayed when the symbol is selected.

You can use two methods to place multiple copies of the same symbol:

• Holding down the right mouse button, drag the symbol into the template.
When you release the right mouse button to place the symbol, you are
prompted with two options. Click Stamp Here, and use the left mouse
button to place multiple copies of the symbol.

• Press the Ctrl key on the keyboard as you drag in a symbol with the left
mouse button. Place the first instance of the symbol while holding down
the Ctrl key. Once you have placed the first symbol, you can release the
Ctrl key and use the left mouse button to place multiple copies of the
symbol.

6. Annotate the drawing.

Use text and dimensioning commands to annotate the drawing. To label,
double-click symbols, walls, or other drawn elements. The active text settings
in the file are used for labels that you double-click.

To edit existing text properties, right-click text and select properties from the
pop-up menu. To move text, click to select; then click the green lock to
unlock.

Move by dragging the text to a new position. Note that text is entered in paper
units regardless of the sheet scale.

7. Finish the drawing.

Change the color of symbols to enhance furniture or identify existing and new
equipment. You can also use connectors to enhance the drawing by adding
communication and computer networking lines.
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The following symbol sets aid in creating office layout drawings.

Content Description

\Program Files\SmartSketch
\Symbols\Diagramming
\Office Layout

Office Layout symbols have special
behaviors for enhanced placement and
modification.
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